Quantcast HELP - Canon PowerShot SX110 IS

+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jul 2013
    Posts
    1
    Rep Power
    0

    Default HELP - Canon PowerShot SX110 IS

    I have the indicated Canon PowerShot. The batteries became exhausted and the camera did not close. I inserted two new sets of Duracell batteries and pushed the power button. Neither set caused the camera to become operational. All that occurs when the power button is pushed is the screen illuminates with the Canon splash screen image and the green LED light flashes for approximately 15 seconds and then the screen goes dark and the LED ceases flashing. The automatic lens cover is not completely closed, but the lens is fully retracted. I have searched the manual to find a part that addresses this problem, but find nothing nor do I find anything akin to a master resetting of the camera. Can anyone please help me? I am in India on a business trip and desperately need the camera. Does anyone know of a "fix" for the camera? If so, would they please copy a response to my email at afortiori1@gmail.com.

    Thank you for any help you can provide.

  2. #2
    Super Moderator/Reviewer
    Join Date
    Jul 2007
    Location
    Virginia
    Posts
    10,970
    Rep Power
    62

    Default Re: HELP - Canon PowerShot SX110 IS

    Unfortunately this is a relatively common problem with Canon cameras when the battery dies while using the camera. You say you replaced the batteries - did you insert new alkalines? Or better yet, new lithium AA's? Remember regular heavy duty batteries don't work.

    Another possible issue may be that the battery compartment door is not closing properly so check that out.

    Finally try removing the memory card and then putting it back. That sometimes works. You can also try completely replacing the memory card.

    If all these attempts don't work you'll have to contact Canon as you may have an internal problem.
    My Gear:
    Panasonic FZ28
    Canon Elph 110 HS
    Canon A720IS (retired)

  3. #3
    Junior Member
    Join Date
    Sep 2013
    Posts
    1
    Rep Power
    0

    Default Re: HELP - Canon PowerShot SX110 IS

    Hi, As this subject is generic, I'd like to post a problem Im having with the same model.

    Pictures taken with my camera lately are in focus at the center and lose focus as you go towards the edges.The viewing screen too has the same issue (focus maintained in objects at the center and lost for the rest).

    The videos are completely focussed though. Same goes for the viewing screen.

    I have been noticing this since my toddler dropped the camera. Although, I cant really say anything went kaput physically, I am noticing this problem only thereafter.

    Can you help me out please?

    Thanks!

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -5. The time now is 03:06 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO 3.6.1