battery discharge K100D

Discussion in 'Pentax' started by ladywing, Dec 27, 2008.

Thread Status:
Not open for further replies.
  1. ladywing

    ladywing New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Has anyone experienced sudden immediate discharge with their batteries? I'm using Nimh rechargeable AA's. Took a trip to Japan and had AWESOME use of the batteries while there. When we came back, all 12 after charging are suddenly discharging after 1 or 2 photos - if I'm lucky. My camera shop will test them for me to see if it's the batteries (bought new ones first too) but is it possible that this is an issue with the camera discharging them?
     
  2. Andy Stanton

    Andy Stanton Super Moderator Super Moderator

    Messages:
    11,164
    Likes Received:
    48
    Trophy Points:
    48
    I've had Sanyo Eneloops for a year and they've never done that.
     
  3. David Rasnake

    David Rasnake News/Review Writer News/Review Writer

    Messages:
    2,170
    Likes Received:
    7
    Trophy Points:
    0
    I guess it's possible that something's shorted in the camera. A simple test, though, would be to put in a set of alkaline AAs and see what happens. If they discharge immediately too, you've found your culprit. If not, looks like the batteries have failed.

    dr
     
  4. Tinderbox (UK)

    Tinderbox (UK) Well-Known Member

    Messages:
    394
    Likes Received:
    2
    Trophy Points:
    0
    Hi.

    What battery charger are you using , do the battery`s get hot!

    John.
     
  5. ladywing

    ladywing New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I think that I've found the issue - the charger itself. I've replaced it and all is well.
     
Thread Status:
Not open for further replies.

Share This Page