Black LCD Screen (M1033) - Any suggestions?

Discussion in 'Kodak (Eastman Kodak)' started by Krista, Dec 15, 2011.

Thread Status:
Not open for further replies.
  1. Krista

    Krista New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hello there -- I have a problem with my Kodak M1033.

    Recently, the LCD screen just turned black. The camera is otherwise functioning; I can take pictures, but I cannot see them as I take them, review them on the screen, or see any menus.

    I know that the LCD screen is not completely broken, however. Tonight, I connected the camera to my computer; and after I disconnected it, the LCD screen worked perfectly for a few minutes. It reverts back to the black screen after a while -- usually when a review/delete or shutter button is pushed. I've tried connecting and disconnecting it from my computer a few more times tonight, and usually can get a few minutes of LCD use afterward.

    Does this sound like a loose LCD screen connection, or a different problem? I'm hoping that something like this would be relatively simple (or not terribly expensive) to fix.

    Any comments on the problem or suggestions as to how I should proceed with this? Thanks in advance!
     
    Last edited: Dec 15, 2011
  2. Andy Stanton

    Andy Stanton Super Moderator Super Moderator

    Messages:
    11,164
    Likes Received:
    48
    Trophy Points:
    48
    It sounds like a screen connection problem to me. Has Kodak given you an estimate on the cost of repair?
     
Thread Status:
Not open for further replies.

Share This Page