Kodak CX7430

Discussion in 'Kodak (Eastman Kodak)' started by DMC, Jun 15, 2008.

Thread Status:
Not open for further replies.
  1. DMC

    DMC New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Hi,
    I bought this camera nearly 3 years ago for £124. I have noticed that the battery life was very short, ~30 mins. At first, I thought it was my rechargeable batteries. I upgraded to higher powered and even higher powered battereies but to no avail. I went camping for a week with no electrics, and I brought 2 sets of fully charged batteries with me and they only just lasted, taking about 5-10 photos a day!

    Anybody know what is causing this, and if it is worth fixing?

    Any help will be greatly appreciated.

    -DMC
     
    Last edited: Jun 15, 2008
  2. Andy Stanton

    Andy Stanton Super Moderator Super Moderator

    Messages:
    11,164
    Likes Received:
    48
    Trophy Points:
    48
    It's obvious your camera has a problem. However, I doubt if it's worth fixing, as your camera is over four years old and can be outdone by cameras costing much less (for instance, a Canon A470).
     
  3. DMC

    DMC New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    OK Thanks. Will replace.
    ooh.. 999 posts!
     
  4. Andy Stanton

    Andy Stanton Super Moderator Super Moderator

    Messages:
    11,164
    Likes Received:
    48
    Trophy Points:
    48
    As of now, 1001!
     
  5. DMC

    DMC New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    1002!

    I am gonna trade it in at CEX and get another used.
     
  6. Tinderbox (UK)

    Tinderbox (UK) Well-Known Member

    Messages:
    394
    Likes Received:
    2
    Trophy Points:
    0
    Hi.

    I have an Kodak CX7530 and have had a similar problem, with low battery showing with fully charged battery`s

    I think it is down to poor battery contacts? , Try cleaning the contacts in the camera!
     
  7. pookey

    pookey Member

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    Hi, yes that is correct, try cleaning the contacts in the camera, sometimes it works
     
  8. pookey

    pookey Member

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
Thread Status:
Not open for further replies.

Share This Page