PowerShot S2 does not turn on

Discussion in 'Canon' started by Tony987, Jan 23, 2009.

Thread Status:
Not open for further replies.
  1. Tony987

    Tony987 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Well, my Canon PowerShot S2 suddenly doesn't turn on. Batteries are re-charged and when turn on it remains without electricity. What could be the problem?
    Note: It worked last night and there was no accident of any sort...

    Thank you,
    Tony
     
  2. Tinderbox (UK)

    Tinderbox (UK) Well-Known Member

    Messages:
    394
    Likes Received:
    2
    Trophy Points:
    0
    Hi.

    First make 100% certain that the battery is charged, also that you dont have a bad connection.

    The S2 has a small cell battery for storing the date/time ect under the battery flap, try removing and re-inserting it, but give it a couple of minutes try pressing the power button while it is out, to remove any residual power.

    Regards

    John.
     

    Attached Files:

  3. Tony987

    Tony987 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    There is no small cell battery for storing the date/time ect under the battery flap...
     
  4. Tinderbox (UK)

    Tinderbox (UK) Well-Known Member

    Messages:
    394
    Likes Received:
    2
    Trophy Points:
    0
    Hi.

    Did you follow the photo i provided, it`s from the manual on the US Canon website page 164 are you certain.

    Maybe the decided to change it to a permanent rechargeable?

    John.
     
  5. Tony987

    Tony987 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Well, I was too quick... The little battery is there but did not solve my problem. Any other suggestion(s)?
     
  6. Tinderbox (UK)

    Tinderbox (UK) Well-Known Member

    Messages:
    394
    Likes Received:
    2
    Trophy Points:
    0
    Hi.

    All you can do is try different battery,s even alkaline to see if it`s a bad contact issue , check for corrosion on the terminals , maybe bend the contacts up slightly.

    If you have a mains adaptor try that!

    Thats all you can do, if nothing works send it back if it`s still in warranty

    John.
     
  7. Blue92

    Blue92 New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Does the camera appear to turn on but the LCD and viewfinder are both black with just the various icons appearing?

    If so it's a rather well known issue with the shuuter sticking in the closed position. I just sent my S2 IS back to Canon for repair. Estimated cost is $135. :(
     
Thread Status:
Not open for further replies.

Share This Page