Screen problem olympus e510

Discussion in 'Olympus' started by Sjoerd de Nijs, Jul 15, 2013.

Thread Status:
Not open for further replies.
  1. Sjoerd de Nijs

    Sjoerd de Nijs New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Hello,
    I'v got a problem with my screen of the olympus e510. Can someone tel me what's wrong?
    It looks like it became wet on the inside, the white glow is not from the picture but is also underneath the screen.

    http://www.flickr.com/photos/98920398@N03/9290088005/ , here the link to the picture!

    Ps; Srry for my bad english :p-
     
    Last edited: Jul 15, 2013
  2. Andy Stanton

    Andy Stanton Super Moderator Super Moderator

    Messages:
    11,164
    Likes Received:
    48
    Trophy Points:
    48
    Your link doesn't work.
    I suggest you either insert your photo into the post or link to a different site, perhaps fflckr.
     
  3. Sjoerd de Nijs

    Sjoerd de Nijs New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I replaced the link, so you can see the picture in flickr!
     
  4. Andy Stanton

    Andy Stanton Super Moderator Super Moderator

    Messages:
    11,164
    Likes Received:
    48
    Trophy Points:
    48
    Your problem appears to be condensation behind the LCD. Did your camera go from a cold environment to a hot, humid one?
    Or it's possible that the LCD developed a leak, as it is made with a liquid inside. That could be a more serious problem.

    Since it hasn't gone away on its own, I recommend contacting Olympus and see what they say.
     
Thread Status:
Not open for further replies.

Share This Page