SP800z Image Quality

Discussion in 'Olympus' started by thunderstruck, Jan 1, 2011.

Thread Status:
Not open for further replies.
  1. thunderstruck

    thunderstruck New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hi guys, my father bought this Olympus SP800uz camera this summer but we have a bit of a problem - the quality of the images is AWFUL! It's like the pictures have been taken with some VGA camera instead of with a 14mp one. I guess there are some settings to be configured or something but I don't know a thing about cameras so I hope you'll be able to help me. :) Thank you in advance!
     
  2. Andy Stanton

    Andy Stanton Super Moderator Super Moderator

    Messages:
    11,164
    Likes Received:
    48
    Trophy Points:
    48
    Hmm. I reviewed that camera for this website and, while I thought the camera had some problems, its image quality was a strong point. Is the camera in iAuto mode?
     
  3. patmokh

    patmokh New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I've been rather disappointed with the SP800uz also. I'm not an expert, but not a total novice either. My main issue has been with color fidelity. It's especially bad indoors, and while I understand there are some things that can be done to trick it into doing better, I don't understand why a camera that expensive needs to be tricked, when those that cost 1/3 of its price can figure it out all by themselves.
     
  4. thunderstruck

    thunderstruck New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Yep. I'll upload couple of pics later to show you what I'm talking about.
     
  5. traineriwas

    traineriwas New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi, new to this forum but I have the same Olympus sp-800uz...it's only about 4 months old, has been gently handled (because I LOVE this camera) but image quality has gone downhill a bit and when I turn it on it now makes a clicking and whirring noise that can be heard when you hold the camera up to take a photo. This has started happening in the past couple of weeks. Anyone else have this happen with this model?

    Also, if I should have started a new thread for this, please let me know!

    Thanks in advance for any advice.
     
  6. Andy Stanton

    Andy Stanton Super Moderator Super Moderator

    Messages:
    11,164
    Likes Received:
    48
    Trophy Points:
    48
    Cameras sometimes make sounds when the image stabilizer is on. Try turning it off and see whether it has any effect on the sounds.
     
Thread Status:
Not open for further replies.

Share This Page